35 lines
618 B
Nix
35 lines
618 B
Nix
with import <nixpkgs> {};
|
|
|
|
let
|
|
types-wtforms = ps: ps.buildPythonPackage rec {
|
|
pname = "types-wtforms";
|
|
version = "3.1.0.20240425";
|
|
format = "setuptools";
|
|
|
|
src = fetchPypi {
|
|
inherit version;
|
|
pname = "types-WTForms";
|
|
hash = "sha256-Sf/B/lV26gc1t2P/935wYN057MZhJ2y9C0cJmSGzpvI=";
|
|
};
|
|
|
|
doCheck = false;
|
|
};
|
|
|
|
in pkgs.mkShell {
|
|
nativeBuildInputs = [
|
|
poetry
|
|
(python311.withPackages (ps: with ps; [
|
|
black
|
|
ldap
|
|
flask
|
|
flask-wtf
|
|
pillow
|
|
kerberos
|
|
(types-wtforms ps)
|
|
]))
|
|
cyrus_sasl
|
|
openldap
|
|
libkrb5
|
|
mypy
|
|
];
|
|
}
|