4
0
Fork 2
mirror of https://gerrit.hackerspace.pl/hscloud synced 2024-10-18 08:27:46 +00:00
hscloud/default.nix
Piotr Dobrowolski ff8a50cb02 ops: colmena integration
Change-Id: I18b9218f2c29a84f7fa769e1a9f561a4385578ca
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1757
Reviewed-by: q3k <q3k@hackerspace.pl>
2024-02-07 18:12:12 +00:00

40 lines
1 KiB
Nix

{ system ? builtins.currentSystem, ... }@args:
with builtins;
let
fix = f: let x = f x; in x;
readTree = import ./nix/readtree {};
# Tracking nixos-unstable as of 2023-07-24.
nixpkgsCommit = "e6b1f2f22b28851d5515eb53d8d5e905aabdad46";
nixpkgsSrc = fetchTarball {
url = "https://github.com/NixOS/nixpkgs/archive/${nixpkgsCommit}.tar.gz";
sha256 = "sha256:0jwwndkdfrv8cfcv47ir1k05gqqxhpi3jkv3dsyflv0wy3pl98g2";
};
nixpkgs = import nixpkgsSrc {
config.allowUnfree = true;
config.allowBroken = true;
# Nixpkgs marked this package as insecure.
# We need it for HTML-to-PDF conversion.
config.permittedInsecurePackages = [
"qtwebkit-5.212.0-alpha4"
];
inherit system;
};
resForPkgs = pkgs: fix (self: (readTree rec {
hscloud = self;
inherit pkgs;
pkgsSrc = pkgs.path;
inherit (pkgs) lib stdenv;
hscloudForPkgs = pkgs: resForPkgs pkgs;
} ./.));
in (resForPkgs nixpkgs) // {
root = ./.;
pkgs = nixpkgs;
hscloudForPkgs = pkgs: resForPkgs pkgs;
}