4
0
Fork 2
mirror of https://gerrit.hackerspace.pl/hscloud synced 2025-01-16 21:13:53 +00:00
hscloud/cluster/machines/dcr01s24.hswaw.net.nix
Patryk Jakuszew a84e9bb884 cluster/machines: replace disk in dcr01s24
Change-Id: I144f23c571267543568a1bd132aea5a8a75db8f2
Reviewed-on: https://gerrit.hackerspace.pl/c/hscloud/+/1853
Reviewed-by: q3k <q3k@hackerspace.pl>
Reviewed-by: implr <implr@hackerspace.pl>
2024-01-24 18:51:09 +00:00

48 lines
1.2 KiB
Nix

{ config, pkgs, ... }:
with builtins;
rec {
networking.hostName = "dcr01s24";
# TODO: undefine fqdn and define domain after big nix change
hscloud.base.fqdn = "${networking.hostName}.hswaw.net";
#networking.domain = "hswaw.net";
system.stateVersion = "19.09";
nix.maxJobs = 48;
fileSystems."/".device = "/dev/vg-nixos-hscloud/nixos-root";
fileSystems."/boot1" =
{ device = "/dev/disk/by-partuuid/0a19d39f-46aa-4088-8067-a02650366e73";
fsType = "vfat";
};
fileSystems."/boot2" =
{ device = "/dev/disk/by-partuuid/a0102b04-15ac-4077-a6ae-bbe9ea4a9a2d";
fsType = "vfat";
};
boot.loader.systemd-boot.enable = false;
boot.loader.efi.canTouchEfiVariables = true;
boot.loader.grub = {
enable = true;
version = 2;
efiSupport = true;
mirroredBoots = [
{ devices = [ "nodev" ]; path = "/boot1"; efiSysMountPoint = "/boot1"; }
{ devices = [ "nodev" ]; path = "/boot2"; efiSysMountPoint = "/boot2"; }
];
};
hscloud.base = {
mgmtIf = "enp130s0f0";
ipAddr = "185.236.240.40";
ipAddrBits = 28;
gw = "185.236.240.33";
};
hscloud.kube = {
control.enable = true;
data.enable = true;
data.podNet = "10.10.20.0/24";
};
}