nibylandia/overlays/nibylandia.nix

32 lines
1020 B
Nix

self: super:
let inherit (self) lib;
in {
cass = super.callPackage ../pkgs/cass.nix { };
notbot = super.callPackage ../pkgs/notbot.nix { };
glitch-soc = let
emoji-reactions = import ../pkgs/glitch-soc/emoji.nix {
inherit (super) fetchpatch fetchurl;
};
file-post-patch = lib.concatMapStringsSep "\n" (f: ''
mkdir -p "$(dirname "${f.name}")"
cp -f "${f.src}" "${f.name}"
'') emoji-reactions.files;
tl-replacer = super.callPackage ../pkgs/glitch-soc/tl-replacer { };
in self.callPackage ../pkgs/glitch-soc {
srcPostPatch = ''${file-post-patch}
${tl-replacer}/tl-replacer ${tl-replacer}/tl-replacer.yaml
'';
inherit (emoji-reactions) patches;
};
python3 = super.python3.override {
packageOverrides = self: super: {
pillow_with_headers =
self.callPackage ../pkgs/pillow-with-headers.nix { };
minecraft-overviewer =
self.callPackage ../pkgs/minecraft-overviewer.nix { };
};
};
python3Packages = self.python3.pkgs;
}